常见问题
常见问题
常见问题

# SDK常见问题

1. SDK使用需要那些设备权限?

SDK 的使用需要用到手机的网络和摄像头权限,如果用户关闭了相关权限,则验证流程会失败并返回对应错误。

2. SDK 兼容性

SDK 支持 Android 4.3 及 iOS 8.0 以上的设备,因为业务需求必须是Android 4.3及其以上才能完成验证功能,4.0可以编译SDK,但是不能使用。

3. Android SDK 如何混淆SDK 代码

添加以下混淆规则,其余按照正常混淆即可。

-keep public class com.megvii.**{*;}

4. Android SDK 如何获取armeabi架构so库

我们SDK 提供的so库是armeabi-v7a 和 arm64-v8a,如果你用的是armeabi的,可以把aar解压,将jni/armeabi-v7a 下的so库复制到项目armeabi目录下即可。

该文档未解决您的疑问?查看常见问题